DISCLAIMER : Please note that blog owner takes no responsibility of any kind for any type of data loss or damage by trying any of the command/method mentioned in this blog. You may use the commands/method/scripts on your own responsibility.If you find something useful, a comment would be appreciated to let other viewers also know that the solution/method work(ed) for you.


How to mount CD-ROM in AIX


Steps to mount a CD-ROM in AIX

1.         Insert the CD-ROM into the CD-ROM drive.
2.         Log in as user ROOT or type su - root to login using the root profile.
3.         Create a /cdrom directory by entering mkdir /cdrom.
4.         Enter smit to add a CD-ROM file system.
5.         Select System Storage Management (Physical & Logical Storage) -> File Systems -> Add/Change/Show/Delete File Systems -> CDROM File Systems -> Add a CDROM File System.

6.         Select a device name, such as cd0. CD-ROM file system device names must be unique.

7.         Type /cdrom to get the Mount Point prompt.
8.         Select OK, or press Enter if using the smit ASCII interface, returning to the previous smit level,
System Storage Management (Physical & Logical Storage).

9.         Select File Systems -> Mount a File System.
10.       For file system name, select /dev/cd0.
11.       For directory over which to mount, select /cdrom.
12.       For type of file system, select cdrfs.
13.       For Mount as a READ-ONLY system, select Yes.
14.       Select OK, or press Enter if using the smit ASCII interface.
15.       Exit smit.

Steps for FC Adapter Firmware update

The steps that are needed to be followed for FC adapter firmware update in AIX is show below
 
 1) To check how many FC adapters are there, same can be used for (datapath) also

lsdev –Cc adapter

pcmpath query adapter(SDDPCM) or datapath query adapter(for SDD Device drivers)



2) To check Firmware Level of FC adapter

lscfg –vpl fcs0
 

check for Z9 from above,Which is TS1.91A5


3) To find out what is the latest firmware level for FC adapter.

Take part number from , lscfg –vpl fcs0 
 




which is 03N7069 and search in google as below,



The URL to find out firmware for above part number is
http://support.bull.com/ols/product/platforms/escala/firmware/dev/fc/files/lp10000/df1000fa.191a5.html
We need to check the below info from above URL

Check part number from below which is affected or not
check for firmware level and  here in this server we have latest firmware level




4) If the lpar is having lowest firmware level, follow the below 
procedure if it has more than 1 FC adapter.
Download latest Firmware and upload to the LPAR ,
a) Unpack the file as follows:

# cd /tmp/ucode

# zcat df1000fa.191a5.tar.Z | tar xvf –

b) Move the microcode to the microcode directory.
# mv /tmp/ucode/df1000fa.191105 /etc/microcode
5) Updating firmware for FC adapters
pcmpath query adapter  

Active Adapters :2

Adpt# Name State Mode Select Errors Paths Active

0 fscsi1 NORMAL ACTIVE 17109 0 20 20

1 fscsi0 NORMAL ACTIVE 17238 0 20 20

updating firmware level for adapter FCS1,for this I need to make FCS1 adapter offline by running the below command

pcmpath set adapter 0 offline

After setting as offline,it looks as

pcmpath query adapter===============================

Active Adapters :2

Adpt# Name State Mode Select Errors Paths Active

0 fscsi1 FAILED OFFLINE 17124 0 20 0

1 fscsi0 NORMAL ACTIVE 17536 0 20 20

pcmpath query device=================

DEV#: 2 DEVICE NAME: hdisk2 TYPE: 2107900 ALGORITHM: Load Balance

SERIAL: 75208013605

==========================================================================

Path# Adapter/Path Name State Mode Select Errors

0 fscsi1/path0 OPEN OFFLINE 188 0

1 fscsi1/path1 OPEN OFFLINE 179 0

2 fscsi0/path2 OPEN NORMAL 181 0

3 fscsi0/path3 OPEN NORMAL 178 0



DEV#: 3 DEVICE NAME: hdisk3 TYPE: 2107900 ALGORITHM: Load Balance

SERIAL: 75208013704

==========================================================================

Path# Adapter/Path Name State Mode Select Errors

0 fscsi1/path0 OPEN OFFLINE 375 0

1 fscsi1/path1 OPEN OFFLINE 444 0

2 fscsi0/path2 OPEN NORMAL 421 0

3 fscsi0/path3 OPEN NORMAL 440 0
6) Now go to /etc/microcode and check fix is there, then run diag
cd /etc/microcode
-rwxr-xr-x 1 10384 10000 664748 Jul 27 2006 df1000fa.191105

diag--------------------------------run this in command prompt, select as



press enter----------------------------------



Select ---------Task Selection (Diagnostics, Advanced Diagnostics, Service Aids, etc.)




Select-----------------Microcode Taks



select------------Download Latest Available Microcode

Now it shows as below



Now you select fcs1,which we made it offline in step 5 and press enter



The below shows installation of new microcode completed for fcs1

press---------f10
7)After installation ,we have to make fcs1 adapter online



fcs1 is offline

pcmpath set adapter 1 online-----------------------run



Now, fcs1 is online

8) Now check paths are normal are not by running
lspath

pcmpath query device


9) Check new firmware level for FC adapter by running
lscfg –vpl fcs1, it should show as


10) The same procedure we need to follow for adapter fcs0,as we followed above from 5th step.

0 fscsi1 NORMAL ACTIVE 17109 0 20 20

1 fscsi0 NORMAL ACTIVE 17238 0 20 20

update firmware level for adapter FCS0,for this I need to make FCS1 adapter offline by running the below command

pcmpath set adapter 1 offline

Working with Crontab


Crontab is the scheduler program used ina unix servers.
Each user can have their own crontab, and though these are files in /var/spool/cron , they are not intended to be edited directly.

If  the  cron.allow  file  exists,  then you must be listed therein in order to be allowed to use this command. 
If the cron.allow file does not exist but the cron.deny file does exist, then you must not be listed in the cron.deny file in order to use this command. 
If  neither  of  these files exists, only the super user will be allowed to use this command.

cronatb -l  --- To view the crontab
crontab -e --- To edit the crontab

MIN HOUR DOM MON DOW CMD /script/location/full/path 

minute 0 through 59

hour 0 through 23

day_of_month 1 through 31

month 1 through 12

weekday 0 through 6 for Sunday through Saturday

Example :
30 08 10 06 * /home/xyz/full-backup
  
  • 30 – 30th Minute
  • 08 – 08 AM
  • 10 – 10th Day
  • 06 – 6th Month (June)
  • * – Every day of the week

Editing crontab

#crontab –l

# crontab -l > crontab.current    ------backup crontab

#vi crontab.current---------Modify changes to backup file

# crontab crontab.current---------To re-enable crontab with modified changes

UNIX History

Unix is a multitasking, multi-user computer operating system originally developed in 1969 by a group of AT&T employees at Bell Labs, including Ken Thompson, Dennis Ritchie, Brian Kernighan, Douglas McIlroy, Michael Lesk and Joe Ossanna. The Unix operating system was first developed in assembly language, but by 1973 had been almost entirely recoded in C, greatly facilitating its further development and porting to other hardware. Today's Unix system evolution is split into various branches, developed over time by AT&T as well as various commercial vendors, universities such as University of California, Berkeley's BSD and non-profit organizations. During the late 1970s and early 1980s, the influence of Unix in academic circles led to large-scale adoption of Unix by commercial startups, the most notable of which are Solaris, HP-UX and AIX, as well as Darwin, which forms the core set of components upon which Apple's OS X, Apple TV, and iOS are based. Today, in addition to certified Unix systems such as those already mentioned, Unix-like operating systems such as MINIX, Linux, Android, and BSD descendants (FreeBSD, NetBSD, OpenBSD, and DragonFly BSD) are commonly encountered. The term traditional Unix may be used to describe an operating system that has the characteristics of either Version 7 Unix or UNIX System V. The companies developed their own Unix flavor and the details are :
IBM - AIX
SUN - Solaris ( now owned by Oracle company)
HP - HP-UX
RedHat - Redhat Linux (RHEL)
These are the most used unix flavors in the servers. They use different architecture for the operating system to bulid in.